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What is Excel? 

Excel is an object (you call it an application) within the Microsoft Office Suite, which is made of several 
other objects, such as a Workbook that contains one or multiple worksheets and charts. The structure of 
a worksheet is similar to a 2D matrix, which is made of columns and rows. On the one hand, the columns 
are designated with letters such as column A or column B. On the other hand, the rows are designated 
with numbers, such as row 1 or row 50. In Excel 2007 and above, Microsoft has increased the number of 
columns from 256 to 16,384 columns and increased the number of rows in the worksheet from 65,536 to 
one million rows. 

Excel’s User’s Interface:  

 

1 By default, Excel includes one worksheet in each new workbook. The user can change the default number 
of worksheets by clicking File/ Options/General Tab  

2 keyboard shortcut (Shift+F11) 

3 Shortcut (Control + Mouse Wheel)  

4 To access Excel functions, either click the fx symbol on the formula box or click on the Formulas Tab to 
access the Functions Ribbon 
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Focusing on Home Tab 

 

Clipboard and Font Submenus are common to all MS Office applications (objects) e.g. MS Word and MS 
PowerPoint; therefore you should be very familiar with these commands. However, some useful shortcuts 
are included in Excel help files, which can be accessed by pressing F1 then type “shortcuts” in the search 
box to display all shortcuts. I hope most of you know the following basic shortcuts, if not please make 
note of them. 

Ctrl+C  Copy, Ctrl+V  Paste, Ctrl+X  Cut, Ctrl+N  New Workbook, Ctrl+P  Print, Ctrl+F  Find, 
Ctrl+Z  Undo, and Ctrl+Y  Redo. 

Tidbit: Press Ctrl+D to copy a cell to selected cells below it. 

Note: when you copy a cell that contains a formula, you not only are copying the value but also copying 
the formula and references. More on this issue later. 

In the Alignment submenu, I only want to bring your attention to the “Merge & Center” button, which 
joins selected cells and centers the content in the middle of the new merged cell. 

 

Another important submenu in the Home Tab is the Number submenu, where you can insert a “$” sign, 
calculate the “%” of the number inserted in the cell, and increase or decrease the decimal. 

   

The last important submenu is Editing, where you can access preset Quick Functions, Create a Series 
and Clear a cell’s content or format.  

    

1- Quick Functions: This list includes Sum, Count, Average, Max, and Min. You can add/change 
more frequently used functions depending on your usage.  
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 Let’s practice together.  

A) Starting at Cell B1 enter the following number in one column {5,12,14,5,8}. 
B) The cursor should be now at cell B6, click Σ, notice that Excel entered the sum of the number. 

Now, practice using the count, average, etc. You can also perform the same operation typing in 
the following formulae 

 =sum(B1:B5)  syntax =sum(start_cell:end_cell) 

 =count(B1:B5)  syntax=count(start_cell:end_cell) 

 =average(B1:B5)  syntax=average(start_cell:end_cell) 

I personally find it easier to use formula instead of the UI, but you are welcome to practice whichever 
method is more comfortable for you. 

                     

Tidbit: If you just want to see the number or the sum without actually carrying out the calculation (i.e. 
previous steps), you can simply select the cells you desire to perform the previous calculation on and look 
down beside the Zoom Bar at the bottom of workbook to observe the outcome. 

 

Tidbit: If you would like to change the default calculated functions, Right-Click on the bottom bar and 
select functions of interest. 

 

Right-Click here 
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2- Fill Function, which you can use to create a series of numbers with a certain pattern.  Let’s 
build your first Series using the Fill Function. In Cell C1 insert the first value of the series you 
wish to create, let’s assume it is zero, then make sure you are selecting Cell C1, click the 
dropdown menu of   then select Series, Excel will prompt you with the message shown 
below. Insert the values shown in the figure and click OK.   

  

3- Clear Function is used to clear the content, format or put comments in selected cells. To 

practice, select cells C1:C6 (they should be filled with number from step 2), click  
dropdown menu and select Clear All, notice all cell contents have been cleared. An alternative 
to delete the content of a cell or a range is to select the cell or ranges and use the delete key 
on the keyboard. Note that using the delete key on your keyboard, only deletes the cell 
contents not the format. 

 

Focusing on the Insert Tab 

 

As a Mechanical Engineer, you are expected to create Charts and Graphs; not only while you are at school 
but throughout your career. In addition, you must learn the lingo of engineers, which incorporates  lots of 
symbols (this is done to make sure no one else but engineers understand what you are talking about and 
sometimes not all engineers will understand it either).  A good chart, as I fully believe, consists of: 

1- Appropriate scale on the abscissa and the ordinate, x-axis and y-axis, respectively. 
2- Axes titles with clearly stated units 
3- Clearly defined legends (i.e. don’t leave it Series1 or Series 2, or any other nonsense title) 
4- Figure title 

Very Important Note: when the problem at hand states to graph the temperature verses voltage (for 
example) that means: Temperature to be plotted on the y-axis and Voltage to be plotted on the x-axis. 
Don’t forget this tip, it will become very handy, “what is before the versus goes on the y-axis and what is 
after the versus lay on the x-axis.” 

Let’s create a good graph together. However, this is may appear to be simple, but I consider it the 
foundation for all good graphs. 
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1- In Cell B1 insert a series header “Voltage (V)”, notice here the title tells you two important 
pieces of information: (1) the physical quantity you are recording; and (2) the units. 

2- In Cell C1 insert a series header “Temperature (°C)”. 
3- In cells B2:B7 insert {1,1.5,2,2.5,3,3.5}, of course you can use Fill Series to insert these values. 

One more trick, if you enter the first two values {1,1.5}, select both cells, then click and drag the 
lower right corner of the last cell in selected range and move the mouse down till you get all the 
number of the series. 

 
4- In Cells C2:C7 insert {23.5,32.3,42.6,53,61.8,72.9}. Your workbook should look like: 

 

5- Highlight all the cells from B1:C7, Select the Insert Tab, then select the Scatter Plot from the 
Chart submenu 

 

Then Select Scatter plot type Scatter with Smooth Lines. Excel will create a graph for you. This Excel 
generated graph needs tons of work to be a “good graph.”  

 



ME209   Dr. Youssef 

CSUN-Mechanical Engineering Department 
© 2014 Dr. George H Youssef 

 

Now take a good look at the graph below and note the differences, I will show you in class how to 
transform the above graph to an acceptable graph in our engineering community. 

  

Note: if you are writing a report, delete the graph title because the graph title should be placed on the 
bottom of the figure with the proper figure number.  

Smart Tags 

A Smart Tag is a small icon that appears automatically in your worksheet after you perform certain actions. 
Clicking a Smart Tag reveals several options. If it bothers you, you can turn it off, by clicking File /Excel 
Options/click Advanced Tab/change the controls in the section labeled Cut, Copy and Paste. 
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Analysis ToolPak and Solver 

Analysis ToolPak is an Add-In to Excel that enables engineers to perform some important engineering 
analysis such as FFT (Fast Fourier Transform) or generating Histograms. Additionally, Solver (another Add-
In) is an optimization and equation solving tool. How would you activate the Add-in, Analysis ToolPak? Go 
to File/Excel Option/Add-Ins Tab, then on the bottom of the window, Manage dropdown menu, select 
Excel Add-Ins and then click Go.  

 

Click the check boxes beside Analysis ToolPak, Analysis ToolPak – VBA and Solver Add-in then press OK. 

 

To access the analysis tools from the Analysis ToolPak, go to the Data Tab and then select the Data Analysis 
button. Remember, neither the Analysis ToolPak nor the Solver is activated by default, if you don’t follow 
the steps above you won’t be able to access the features. 
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Once you click Data Analysis, Excel will prompt you with a list of available tools. You will learn how to use 
some of these during your academic career.  

 

Let’s dig deeper….. 

Formula: 

We create spreadsheets, in the first place, to automate a set of calculations. Therefore, the spreadsheet 
is a dynamic environment and the formulas are the building blocks of such environment. Formula entered 
into a cell: 

1- Start “=” sign  
2- Include operator such “+ - / *” 
3- Numbers or text string (yes! You can perform formulas on text) 
4- Worksheet functions, it is the most interesting to us Engineers. 

 

Early in this tutorial, we introduced some functions (i.e. sum, average, min, max etc.), Excel has a lot more 
functions, to review more functions go to Excel’s Help (press F1) and select Function reference. I advise 
you to browse through the function reference and read the help file for few functions.  

Example: The diameter of a steel shaft is 20 cm, calculate the area in m2. (area=πd2/4) 

 

 

Tidbit: to show the formulas in a cells press Ctrl+~ 

Here is a list of common errors that occur when using formulas: 
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Very Important Note: when performing a formula that involves an array, in order to perform the 
calculation you must press Ctrl+Shift+Enter. For example, let’s assume you are to multiply A matrix (3x3) 
with B matrix (3x1), the resultant matrix is expected to be 3x1: 

 Select 3 rows and 1 column 

 Type =mmult(A,B) 

 Ctrl+Shift+Enter 

                   

References: 

As you saw in the previous example, the formula references one or more cells. Cell references come in 
four styles. Creating a good spreadsheet is hinged on proper referencing.  

 Relative Reference: the reference is fully relative. When the formula is copied, the cell reference 
adjusts to its new location. Example: A1. 

 Absolute Reference: the reference is fully absolute. When the formula is copied, the cell 
reference does not change. Example: $A$1. 

 Row Absolute Reference: the reference is partially absolute. When the formula is copied, the 
column part adjusts, but the row part does not change. Example: A$1. 

 Column Absolute Reference: the reference is partially absolute. When the formula is copied, the 
row part adjusts, but the column part does not change. Example: $A1. 

Tidbit: To toggle between all four styles of reference, press F4 repeatedly. 

Example: The original length of a copper rod is 10 cm, the change in length is monitored in a tensile 
strength test frame. What is the corresponding stress at each step? Consider the modulus of elasticity, 
E= 117GPa. (1D Hooke’s Law: σ=Eε) 
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You also can reference cells from different worksheets and even from different workbooks. Here is an 
example of a formula that uses a cell reference in a different worksheet. 

=Sheet2!A1+1  

This formula calculated the sum of cell A1 in Sheet2 of the workbook and one.  

=[workbook_name.xlsx]Sheet1!A1 

This formula reference cell A1 from Sheet1 form file workbook_name.xlsx  

Names: 

Thus far, you refer to cells by their column and row numbers. However, Excel provide us with a very 
powerful and very useful feature; the ability to provide meaningful names to cells, ranges, columns, 
rows, even charts and formulas. Ways to assign names to cell and range: 

 Choose Formulas  Defined Names  Define Names  Define Names to display the New 
Name dialog box. 
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Remember that no spaces are allowed, for example if you want to name a cell Young Modulus  
Young_Modulus. 

 Ctrl+F3  displays the Name Manager dialog box (Formulas Defined Names  Name 
Manager), then click New button. 

 

 Select the cell or range and then type a name in the Name Box and press Enter. 
 

 
 

 If the worksheet contains text that you would like to use for names of the adjacent cells or 
ranges, select the text and the cells to be named and choose Formulas  Defined Names  
Create from Selection. 

              

Tidbit: Now you defined an array by the top row and left column, you can use the intersection operator 
to reference cells i.e. =Qrt_2 South 
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 Naming Constant: let’s say you are working on a thermodynamic project and you will use 
Boltzmann’s Constant many times throughout the project (Boltzmann Constant = 1.3806503 x 10-
23 m2 kg s-2 K-1). To add boltzmann constant, go Formulas  Define Names Define Name  
enter data as shown below the press OK. Thereafter, you can use the constant anywhere in the 
workbook =boltzmann.  

 

Counting and Summing: 

1- The last topic in this brief tutorial is counting and summing, I understand that counting and summing 
was introduced before, but that was the simplest form. How about conditional counting or 
conditional summing? This is best introduced by examples, for which I refer you to [counting and 
summing examples.xlsx], I modified this file from Walkenbach, J., Excel 2007 Power Programming 

with VBA, Wiley, 2007. 

 


